PingPlotter Manual

Auto-Saving of Data

PingPlotter v5 saves data automatically.  In V4, it didn't save automatically, and sometimes important data wasn't available when you needed it (unless you did some configuration that didn't always think the way you do). This is something that shouldn't happen to you in V5. In PingPlotter 5, it should "just work", saving what you want, discarding what you don't (if you show it what kind of stuff you don't want).

PingPlotter 5 writes all data in real-time to its local data store. This helps make sure that none of your data is lost at any point (for instance - if there is an unexpected restart, a power failure, or any other event that would put data data at risk).

Long-term sessions (a session is a set of collected data from a trace to a target) are saved continuously, and when you scroll back in history, the data is retrieved from disk. Closing and restarting will resume those sessions. Short term sessions are saved continuously, but if you don't collect data long enough, they are marked for deletion when closed.

When a session is marked for deletion, it will be fully deleted after you close and reopen PingPlotter five times.  If you closed a session you really wanted to continue, you can reopen that session within 5 stop/restarts and continue.  This behavior is a direct result of feedback from our users (and us) that prompting to save on close was frustrating.

Configuring the definition of "short term" sessions

The auto save settings can be configured in PingPlotter by going to either "Edit" -> "Options" -> "Auto-Save" (on Windows) or "PingPlotter" -> "Preferences" -> "Auto-save" (on Mac).

 

There are a few different options for how to recognize a session as one you want to keep around, or one you want to throw away when done.

  • "Always" - this will keep every target's data in PingPlotter's datastore. If you start tracing a target and stop after 3 samples, that "session" will get marked to keep.
  • "After:" - this setting will only keep sessions that have met or exceeded the timeframe that is entered. Use "5 minutes", or "1 hour" or similar.
  • "Only when selected" - this will result in PingPlotter auto-saving data, but marking it to discard when you close. This is a great option if you have a handful of long-term targets that you always want to collect from, but you want to occasionally mix in some targets that you don't want to stick around.

Keeping an individual session

If you're collecting data from a target and you decide you want to keep it (and you're in a mode where it's not yet marked to keep), you can switch to "Keep" mode (or discard mode) manually at any time. To do this, open a trace window (if it's not already open, use the "All Targets" summary to find it, then open from there), and right click on the target tab. Here we have options to "Discard on close," or "Keep (auto-save)."

The tab's "close" icon will show an "X" to indicate that this data will be discarded on close, and a checkmark to show that it will be kept.

Finding a session

Once you've collected data but you've closed it, how do you reopen it (or delete it, or export it, or continue tracing)?

The previous trace sessions can be found in PingPlotter by going to "File" -> "Manage Sessions." From the session browser, we have the options to reopen or delete a previous session, as well as the option to export a session (which will save off a .pp2 file).

There are four different persistence types in the session browser:

  • Active - any trace sessions that are actively collecting data
  • Pause - any trace sessions that are open in PingPlotter now, but are paused
  • Archived - any inactive trace sessions that have been saved and are closed
  • Will Delete - any inactive trace sessions that haven't been set to save. These will eventually be deleted.

All of the data in PingPlotter is saved to a file titled "sessions.ppdata" in one of two locations. If we're running PingPlotter as a Windows service the file's default location is in the C:\ProgramData\PingPlotter 5\ folder. If we're running the program as an application, then the file's default location is in our user application data folder C:\Users\**username**\AppData\Roaming where **username** is the username of the currently logged in user.

There is an option in the Auto-Save to change the default location of the sessions.ppdata file. If we specify a different location to store the file, we'll want to make sure to close and relaunch the program to get the changes to take effect. If we're running PingPlotter as a Windows service, then we'd need to restart the service (or restart the machine) to store the changes.

Long term monitoring considerations

Now we know that data is being saved automatically, and you can open it, export it, and delete it from the session browser. Is there anything else to worry about?

Hopefully not!

You might be worried about configuring how much data to hold in memory (this was a common problem in PingPlotter 4 as more targets were added). One of the advantages of saving data automatically and real-time is that we can count on it being there - and we don't need it in memory. PingPlotter automatically keeps a small amount of collected data in memory - enough for alerts to work, and your graphs to have accurate statistics. The rest it clears from memory and leaves on disk. If you scroll back in time, the data will automatically be pulled from disk for display and analysis. When you're done using data, it will be dropped from memory automatically.

There are a few things you can do to optimize memory and CPU use if you're tracing to a lot of targets (we'd call 250 "a lot", although that number is going up as we optimize more).

If you're tracing a long time to a lot of targets, you might:

  • Hide target tabs for any targets you're not actively looking at. This minimizes statistics calculations and memory use.
  • If you have a lot of targets with a lot of data used, don't scroll back a year with 200 targets on the all summaries tab. This will feel pretty slow as all 200 targets need to load from disk. When you need this, scroll back on a single target, or create a summary with just the ones you're interested in. We are continuing to improve this experience as PingPlotter gains capabilities.

 

**Some of the features listed in this topic are only available in PingPlotter Pro and/or PingPlotter Standard. See our product comparison page for more details**

 

This manual is specific to PingPlotter Version 5

Older versions can be found here.